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AWRDE QUICK REFERENCE
This version of the Quick Reference Guide is an abbreviated version used for printing. You can access the full version of this document
in the AWR Design Environment (AWRDE) by choosing Help > Quick Reference. This menu command will open any document
named Quick_Reference.pdf in the AWRDE installation folder.

ADDITIONAL RESOURCES AVAILABLE

These links are also available in the AWRDE from the Help > AWR Web Site menu.
1. AWR KnowledgeBase - http://www.awrcorp.com/download/kb.aspx
2. Example Website - https://awrcorp.com/download/examples80/default.aspx
3. Script Website - https://awrcorp.com/download/scripts/default.aspx
4. API References - http://awrcorp.com/support/apidocs.aspx

PROJECT BROWSER AND DESIGN ENVIRONMENT

Design Environment

Use these keystrokes from anywhere in the AWRDE:

DescriptionHot Key

These commands are common to most window types (circuit schematic, system diagram, layout, EM layout, global equations and
output equations).

DescriptionHot Key
Scroll up and downMouse Wheel
Scroll right and leftShift-Mouse Wheel
Zoom in (centers on the cursor) and outCtrl-Mouse Wheel
Scroll upUp Arrow
Scroll downDown Arrow
Scroll leftLeft Arrow
Scroll rightRight Arrow
Zoom outNum -
Zoom inNum +
View AllHome
View AreaCtrl-W
View PreviousEnd

PROJECT BROWSER AND DESIGN ENVIRONMENT

Design Environment

Use these keystrokes from anywhere in the AWRDE:

DescriptionHot Key
Copy selected itemCtrl-C
Cut selected itemCtrl-X
Paste selected itemCtrl-V
Undo last operationCtrl-Z
Redo last operationCtrl-Y
Open the Optimizer dialog boxF7
Display a list of all variables used in a projectShift-F7
SimulateF8
Save a projectCtrl-S
Open the TunerF9
Cycle through AWRDE windows in one directionCtrl-Tab
Cycle through AWRDE windows in the opposite directionCtrl-Shift-Tab

Most actions are customizable to create your own hot key, toolbar button, or menu option. Choose Tools > Customize to add your
own customizations for toolbars and menus and Tools > Hotkeys to add your own hotkey commands.

Zooming and Scrolling

ADDITIONAL RESOURCES AVAILABLE

These links are also available in the AWRDE from the Help > AWR Web Site menu.
1. AWR KnowledgeBase - http://www.awrcorp.com/download/kb.aspx
2. Example Website - https://awrcorp.com/download/examples80/default.aspx
3. Script Website - https://awrcorp.com/download/scripts/default.aspx
4. API References - http://awrcorp.com/support/apidocs.aspx

PROJECT BROWSER AND DESIGN ENVIRONMENT



Project Browser
Change model description views in the Elements Browser by right-clicking in the lower left window to change the model display.
The most useful setting is the Show Details view which provides the model name and a brief description of the model.
Wizards can add functionality to the AWRDE. See the Wizards node of the Project Browser for available Wizards.
Open an item by double-clicking it, or right-click in the Project Browser and choose Open Project Item to select an item to open
from a list of all items in your project. In the Open Project Item dialog box, the list of items is as you type, and the item
that best matches your input is highlighted.
Open a example by choosing File > Open Example or Help > Open Example to a list of examples by name or
keyword. Press the Ctrl key and click over the column header on which you want to .
Show all previously opened projects by choosing File > More Projects to display and a list of all projects you have opened;
by rank, project (name), (date) last opened, or path. Press the Ctrl key and click over the column header on which you want to

.
Browse to and folders by choosing Help > Show Files/Directories to open a Directories dialog box that displays
all of the and folders the AWRDE uses. Double-click a folder or to open it.
Add/delete/rename by right-clicking an item to display a menu with options to add, delete, rename, import/export, collapse/expand,
link to, view properties for, and more.
Delete without by pressing the Shift key while deleting Project Browser nodes (such as graphs or schematics) to
bypass the default deletion
Create an output equation identical to a measurement by dragging and dropping a measurement from the Project Browser
into the Output Equations window.
Copy an item by dragging it up to its parent category in the Project Browser and dropping it (schematics/system diagrams, data

EM structures, graphs and measurements only). The new item has the same root name appended with "_1" so it displays
next to the original item in the Project Browser.
Add a subcircuit to a schematic window by right-click dragging and dropping a schematic from the Project Browser on an open
schematic window.

Window in Window
Create a window in a window by dragging and dropping an item from the Project Browser to an active window. The cursor
changes to allow you to click and drag to draw the desired window size.
Resize and align multiple windows by right-clicking the toolbar and choosing Align to display the Align toolbar with various
alignment options, and then by selecting the window-in-window objects and the proper align command. You can also size each
selected window identically.
Edit window-in-window views by double-clicking the view or by selecting it, right-clicking and choosing Activate View. When
editing these windows you are editing the original object (for example, the schematic or graph). Click once to select and move an
object.

CIRCUIT SCHEMATIC / SYSTEM DIAGRAM

Shortcuts for common items:

DescriptionHot Key
Add a ground connection (schematic only)Ctrl-G
Add a port (schematic only)Ctrl-P
Add an equationCtrl-E
Add a subcircuitCtrl-K
Add an elementCtrl-L
Add textCtrl-T
Select allCtrl-A

Adding/Placing an Element
Add or place an element by pressing Ctrl-L or choosing Draw > More Elements to a list of elements by name, description,
or path. Press the Ctrl key and click over the column header on which you want to . While typing, the item that best matches



your is You can Enter or OK for You can using
for you can "micro line" for

for any PDK or

you of a or you
an you can:

DescriptionKeystroke
RotateRight-click
MirrorCtrl-Right-click
MirrorShift-Right-click

NOTE: of an

Schematic / Diagram Connectivity
For a substrate Add Model Block
Start wiring by a cursor W
Start a wire from the middle of another wire or node by choosing Add Wire
Remove a previous point by you a
Controlling wire direction: a on of cursor

auto wire deletion by Auto wire cleanup in on Schematics/Diagrams
Options > Project Options an is

is If
Highlight a net by a choosing Net Highlight On a in a

Any in for in
Create a bus net by a choosing Create BusNet
Edit net properties by a choosing Edit Net Properties
Disconnect an element by Ctrl
Move an element orthogonally only by Shift an

Custom Symbols
Create a custom symbol using Project > Circuit Symbols
Create a custom symbol for a subcircuit using AWR Symbol Generator Wizard Wizards of

can on or of your

Element Selection
Restricted selection: a or Restrict
Selection a on or off for off

for
a

Shift select multiple models or
select all objects completely inside your drawn selection area

Shift in your in your
Ctrl-A

If Ctrl

Element Symbols on Schematics/System Diagrams

an a
Edit element properties/parameters in
Toggle enable or disable of
Swap an



Rotate or selected elements.
Change the view (Zoom In/Out, V Area, V All).
Display the for the element.

Helpful Operations
Add the following standard unit to element models to simplify the entry of model parameters: a, f, p,

n, u, m, c, d, mil, k, meg, g, t. These follow SPICE rules: they are not case sensitive, they must follow the number
directly without a space in between, and any characters directly following the are ignored.

a Double-click a model parameter within the schematic to display a text box. Press Tab to move
to the next parameter and Shift-Tab to move to a previous parameter.

for many Select all of the elements to edit, right-click any of the elements and choose
Properties. All common model parameters can be edited at once.

an Double-click the model name and type in a new name. For example, double-click "RES" and type "CAP"
to replace a resistor with a capacitor.

many Select all of the elements to replace, then in the Element Browser the element with which to replace
them. Right-click that model and choose Replace Schematic Selection. The Preserve Parameters option retains any common
model parameter values while Replace Parameters uses the model's default parameters (this is useful when replacing with library
elements).
Make a edit the ID and add the iteration count, for example change "ID=R1" to "ID=R1[0:3]" to make four
resistors for simulation and layout.

element In the Element Options dialog box for each element, Symbol and Layout tabs allow changes to the
element symbol and layout.

Tuning

Tune T Click on a variable or parameter to make it tunable.

F9: Open the Variable Tuner with controls for each tunable parameter, or click the Tune button on the toolbar.
Press the Shift key while tuning to a only when you release the mouse button.
Press the Ctrl key while tuning to layout at every tuner instead of when you release the mouse button.
With the Variable Tuner open, click on the square at the top right of an item being tuned to turn off an for .
If an element parameter is set for tuning but the element has not been constrained, the upper tuning limit is 2X the nominal value
and the lower tuning limit is 0.5X the nominal value. You can change this by on . If a
parameter has constraints, those values are used as the tuning limits.

LAYOUT

Shortcuts for Common Items

Hot Key
Add textCtrl-T
Select allCtrl-A
Draw ellipseCtrl-E
Draw pathCtrl-L
Draw polygonCtrl-P
Draw rectangleCtrl-B
Toggle grid snapCtrl-G
Toggle orthogonal modeCtrl-O
Start measure toolCtrl-D



Common Operations
Coordinate Entry: While drawing a rectangle, polygon, or path, or while dragging an object or placing a cell, press Tab or the
Space Bar to specify a location using relative or absolute coordinates.
Snap Shape: Press Ctrl to snap the mouse to endpoints, midpoints, and edges during dragging, moving, stretching, and measuring
operations.

Layout Selection
Restricted selection: Right-click anywhere over a layout with nothing selected and choose Restrict Selection to display a Restrict
Selection dialog box to turn on or off different items for selection. When items are turned off they cannot be selected for the
following operations.
Click a shape to select a shape.
Press Shift to select multiple objects or remove objects from those selected.
Press Ctrl-Shift when selecting a shape that overlaps other shapes to cycle through the overlapping shapes.
Click and drag to select all objects inside your drawn selection area.
Shift-click and drag to include in your selection all objects that are partially enclosed in your drawn selection area.
Press Ctrl-A to select all objects.
Choose Layout > Layout mode properties to specify manual or auto-selection. Auto select selects any item clicked. Manual
select requires a Shift-click to select and deselect objects.

Helpful Operations
Aligning Shapes: Select all shapes to align, then choose Draw > Align Shapes to view alignment options. Note that the item
selected is the reference point for the alignment.
Boolean Operations: Select all the shapes for the Boolean operations (AND,OR,XOR, etc), and choose Draw > Modify Shapes
to view the operators.

Measuring Distances
Temporary ruler: Display a temporary ruler to measure a distance when you click and drag. Choose Draw > Measure, press
Ctrl-D, or click the Measure button on the toolbar button to activate. When you release the mouse button the ruler goes away.
Layout ruler: Display a set layout ruler to measure a distance when you click and drag. The layout ruler remains on the screen
and has properties. Choose Draw > Layout Ruler or click the Ruler button on the toolbar to activate. To
ruler properties select the ruler, right-click and choose Shape Properties.
Dimension line: Display dimension lines that show the distance between two selected points when you click and drag. Choose
Draw > Dimension Line to activate. To dimension line properties, select the line, right-click and choose Shape Properties.

Layout Modes

Layout modes allow you to different layout settings and then easily switch amongst them while working in the Layout
Editor (such as layer visibility, selection drawing dim, and many more).

Layout Mode Setup: To set up different layout modes, in a Layout window, choose Layout > Layout Mode Manager to open
the Layout Mode Properties dialog box. Click Edit to view the Layout Editor Mode Setting dialog box with separate tabs and
options for controlling different layout modes.
Layout Mode Selection: In a Layout window, click the Layout Editor Mode toolbar button to quickly select different layout
modes.

Routing MTRACE2, MCTRACE or MTRACEM Elements
Double-click the cell to display "drag handles".
When the cell is a straight line, drag the middle handle to add a "dogleg" bend.
Drag the endpoints to stretch or shrink the trace.
With one or more bends, press Ctrl and drag a "midpoint" handle to add another bend.
Press Ctrl and drag an endpoint to change the angle of the last bend.
Drag a "midpoint" handle to stretch the trace while maintaining a constant length.
Press Shift and drag a "midpoint" handle to stretch the trace without maintaining a constant length.



To redraw the trace from scratch, double-click on either end point. Click to place vertices, and double-click again to the
trace. The entire trace must be re-routed; a segment cannot be added from pin2.

Stretching Layout Shapes
Drag corner handles to stretch orthogonally.
Start dragging the element, then press Shift and drag the corner handles to stretch without angle snap.

GRAPHS

Shortcuts for Common Items

DescriptionHot Key
Freeze tracesCtrl-F
Clear frozen tracesCtrl-U
Add markerCtrl-M

Common Tasks
Save data from a graph to a text by choosing Graph > Export Trace Data.
Add a measurement on a graph by right-clicking the graph and choosing Add New Measurement.
Modify a measurement on a graph by right-clicking the graph and choosing Modify Measurements.
Change measurement order in a graph by selecting the measurement in the Project Browser, then pressing Alt and using the up
and down arrow keys on your keyboard.

Tabular Graphs
Change the display precision of tabular graph numbers by right-clicking the graph and choosing Properties to display the
Tabular Graph Format dialog box to specify options.
Change column header text by right-clicking the graph and choosing Properties to display the Tabular Graph Format dialog
box to change the display for each measurement.

Rectangular Graphs
Limit the axes of a rectangular graph after the simulation is complete by right-clicking and choosing Zoom Data, and then
clicking and dragging to the area you want If you click and drag over the x-axis of the graph, this operation
zooms only in the x-direction.
Reset the axis limits by right-clicking and choosing Restore Axis Setting.

Markers
Marker options are dependent on the type of graph. Most graphs support markers. Right-click a marker to view marker options.
Marker Reference: Any other markers attached to the same trace show a delta value from the reference marker.
Search: Search for values of the trace.
Rectangular Graphs: Search for min and max values of the trace.
Rectangular Graphs: Add horizontal and vertical line markers.

ELECTROMAGNETIC STRUCTURES

The AWRDE has its own EM simulator called EMSight. The AWRDE also has a socket for plugging 3rd-party EM tools into the
environment.

User Interface
In an EM structure window, click the Layout tab in the lower left to access controls for drawing and viewing EM structure layout
objects in the Layout Manager.
By default, the Drawing Layers pane is hidden from view and only the cross-section view displays. To display the Drawing Layers,
click and drag on the bottom of the cross-section view window to expose this window.



Viewing Mesh, Currents, and E-Fields

(For simulation in EMSight) Currents and are viewed in the 3D view of an EM structure, while mesh can be viewed in the
2D or 3D view. These are added as annotations. To add mesh, currents, and , right-click the EM Structure in the Project
Browser and choose Add Annotation to modify settings in the Add Annotation to the EM Structure dialog box.

Simulation Considerations

The following are general guidelines applicable to simulation in EMSight. If you are not comfortable with these, you should do
simple experiments with your process technology so you can vary each of the following and compare results.

De-embedding distance: You should de-embed 2X your substrate height or 2X your line width, whichever is greater.
Spacing to the The sidewalls in EMSight are perfect ground, so you should space any lines at least 2X your substrate
height from the edge. For antennas, you should probably space even further than this.
Top and bottom settings: For a walk-through of these issues, see the example named EM_top_and_bottom_enlcosure_effects.emp
by typing this name in the Open Example Project dialog box (choose File > Open Example).
Types of ports: To understand the different types of ports, see the example named EM_Ports.emp by typing this name in the
Open Example Project dialog box (choose File > Open Example).

EQUATIONS
You can display the value of any equation by typing the name of the equation followed by the : symbol. When you simulate or
press F6 the variable will update to display the stored value of the variable.
You can add multiple equations in one equation block. While typing an equation press Ctrl+Enter to create a new line in the
equation.

Below is a list of all the function names used in the AWRDE. Please see the full documentation for a description of each function

FunctionFunctionFunctionFunction
_FREQH3_FREQH1_FREQH1_FREQ
acos(x)abs(z)_TEMPK_TEMP
angle(z)amin(x)amax(x)acosh(x)
asize(x)asinh(x)asin(x)ans=x mod y
atan(x)asum(x)assign_swpunit(x, unitType)assign_sweep(x, y)
bin(str)awg_dia(x)atanh(x)atan2(x, y)
complex(real, imag)col()cint(x)ceil(x)
cosh(x)cos(x)conj(z)concat(a, b)
ctok(x)ctof(x)csum(x)cstr(x)
db_pow(x)db(x)DataFile(name, "c")type, args)
exp(x)der(x, y)deg(x)dbpolar(dbMag, ang)

val1, val2)val)val)
heaviside(x)ftok(x)ftoc(x)fmod(x,y)
if(cond, trueval, falseval)hypot(x,y)histogram(x, bin_type)hex(str)
interp(type, x, y, new_x)integrate(x)int(x)imag(z)
lin_pow(x)lin(x)ktof(x)ktoc(x)
max(a, b)log10(x)log(x)lin_reg(x)
points(start, stop, points)plot_vs(y, x)oct(str)min(a, b)
real(z)rad(x)pow(x,y)polar(mag, ang)
sinh(x)sin(x)sign(x)row()
str2dec(str, base)stepped(start, stop, step)stack(n, vec)sqrt(x)
swplin(start, stop, points)swpdec(start, stop, points)subsweepi(meas, start, count)subsweep(meas, x1, x2)
swpstp(start, stop, step)swpspanst(center, span, step)swpspan(center, span, points)swpoct(start, stop, points)
tanh(x)tan(x)swpvals(x)swpunit(x)
vlen(x)unwrap(x, d)transpose(x)
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